Integration Broker Messages Stuck in New State – PeopleSoft Tutorial
9

Integration Broker Messages Stuck in New State

 

PeopleSoft Integration Broker is tricky and sometimes when issues arise, it can take you a long time to resolve the issues unless you troubleshoot issues in a logical and systematic way.

I will lay out the steps, which you should check. Following these steps will resolve your issue in 99% of the cases. I did not find any material available online, which can help you troubleshoot issue of integration broker messages in new state.

Let’s have a look:

Issue – PeopleSoft Integration Broker Messages Stay in New Status

  1. Check if PUBSUB enabled application server is not down.
  2. Verify that PUBSUB is enabled in psadmin.
  3. Check the status of the application server and verify that the following 6 programs are running (Fig. 2): PSBRKDSP.exe, PSBRKHND.exe, PSPUBDSP.exe, PSPUBHND.exe, PSSUBDSP.exe and PSSUBHND.exe
  4. Check the Domain status in Integration Broker -> Service Operations Monitor -> Administration ->  Domain Status : You should have domains which are Active. Update the status if they are inactive by using “All Domains Active”
  5. Check Domain status (as in Fig. 1) – It is possible that only one domain is configured for PUBSUB services and is set as a slave domain in psappsrv.cfg. It is also possible that all the domains are set as slave in case of multiple domains (picture below). A value of 0 will initialize the PUB/SUB servers in normal (Master) mode.
  6. You will need to bounce the appserver if you change the settings of Domain Slave Mode. Also, If domains change the status back to inactive after you manually update them to active – you should restart the pubsub enabled application servers.
  7. Check the Queue status in Integration Broker -> Service Operations Monitor -> Administration ->  Queue Status : The status of the queue should not be Paused. If it is paused, run it.
  8. Ping Node to verify that you get the Success (117,73) message. Do this ping node test for all the nodes, which are not processing the messages, including the default local node.
  9. Check if there are messages stuck in the following status: “Timeout” or “Started” or “Working” – if messages are in this status, it means that they are being submitted again and again to be processed. This causes “New” status queue to increase. Debug the reason why they are stuck in this state or cancel them to allow the new ones to be processed. Make sure that you can work on the cancelled ones later on.
  10. Bounce the PUBSUB enabled appserver if nothing works.

Click Here To Learn PeopleSoft Integration >>

both integration broker domains as slaveFig. 1 – Both domains are slave

 

integration broker servicesFig. 2 – Integration Broker programs

Click Here To Learn PeopleSoft Integration >>

Apurva Tripathi
 

Apurva is a PeopleSoft consultant and a big advocate of everything PeopleSoft. He is also a technology enthusiast and loves learning and implementing newer and open source technologies. He spends his spare time updating this blog and likes to read books on self help and productivity.

  • […] first thing you should do it make sure you’ve checked all the possible causes mentioned in Integration Broker messages stuck in new state and if the issue persists, read […]

  • Aravind says:

    cool article.Thanks.

  • […] to resolve it. What did I do the last time? I wrote a post on one such issue some time back – Integration Broker Messages Stuck in New State. In this post, you will find troubleshooting steps for a similar topic – Unable to find a […]

  • Anh Nguyen says:

    May I add in 1 more helpful solution: after a tools upgrade, we had AC on PT8.53.xx connected to HR 8.51.xx and FS on 8.52.xx; any of the above and boucing the app servers did not solve the issue. On GSC, found a suggestion to run HCM registry refresh, after clearing the caches, bouncing the servers. It worked, all NEW messages were processed; this was due to a higher version of tools (8.53.14) connecting to lower versions (8.52 and 8.51).
    Enjoy.

    • jigisha thakkar says:

      I’m in the exact situation you describe here. I am higher tools connecting to lower version all message are in New status. I’ve tried all the above suggestions and I think I may have to try a registry refresh and clearing caches. I’m not a sysadmin, so could you provide more details on how to do the refresh and also where to clear the pertinent caches on the servers? Thanks!!

  • Shan says:

    Great article, I am having a query. Is there a way to find the corresponding queue name, if we know the server name?

  • Swati Sharma says:

    Hi Apurva,

    We are trying to run sync between HCM 9.2 and ELM 9.2 and facing the same problem i.e. messages are stuck into NEW status in Pub contract.

    I have followed all your steps mentioned above and verified everything. But the issue still persists.

    Could you please advice? It will be a great help.

    Thanks

  • Sathish Kumar says:

    hi ,
    i still have same issue. can anybody had success. done status.

  • >

    Download Complete List of PeopleTools Tables List. Never Again Google It !